OZO3勤怠にて障害が確認されたため、
障害内容と対応等につきまして、下記にご報告させていただきます。
-----------------------------------------------------------------
■発生対象の環境、バージョン情報、条件等
-----------------------------------------------------------------
・ManageOZO3 3.21.0以降(クラウド版、オンプレミス版)
・勤怠管理の計算項目の計算式に拡張事由を使用されている場合
-----------------------------------------------------------------
■障害内容
-----------------------------------------------------------------
<内容>
①拡張事由を計算項目の計算式に設定されている場合、勤務表表示時にエラーが発生することがある。
②拡張事由を計算項目の計算式に設定されている場合、計算結果が不正となることがある。
<原因>
①勤務表表示時の特定条件で登録された拡張事由のデータ取得処理に不具合がございました。
②特定の手順で追加された拡張事由を計算項目の計算式に登録した場合、登録処理に不具合がございました。
-----------------------------------------------------------------
■対応内容
-----------------------------------------------------------------
修正プログラムを提供させていただきます。
クラウド版 :2020年12月15日(火) 15:25 修正パッチを適用しました。
※適用作業中も通常通りサービスはご利用いただけます。
オンプレミス版:2020年12月15日(火) 15:00 修正パッチをリリースしました。
※オンプレミス版をご利用の場合はお客様にて適用をお願いいたします。
※3.21.0にて修正プログラムのご提供になります。
※カスタマイズ機能をご利用のお客様
カスタマイズ担当者までご確認・ご相談をお願いいたします。
※ご注意※
上記「■障害内容」の②につきましては、お手数ではございますが、再設定が必要となります。
下記「<手順>」にて、計算式の再設定をお願い致します。
<手順>
1)勤怠運用設定>基本設定>計算項目設定にて該当の計算式を編集
2)計算式内の拡張項目を選択
3)項目で該当の拡張項目を選択して追加
4)登録ボタン押下
この度は、ご迷惑をおかけいたしまして、誠に申し訳ございません。