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【OZO】勤怠申請の承認ルートLv1の自動所属ルートが正常に反映されない場合がある ※2.16.0用Hotfix有り

更新日
勤怠申請の承認ルートLv1で、自動所属ルートがONと設定されている場合に、正常に自動所属が反映されない場合がある。
発生対象の環境、バージョン情報、条件等
  • ManageOZO バージョン2.15.3以降をご利用中で勤怠管理を利用している
  • 新規ユーザー登録後に、下記画面から申請を行った場合
  • 既存ユーザーの所属グループ変更後に、下記画面から申請を行った場合
    • [勤怠管理] - [勤務表] の勤務表申請
    • [勤怠管理] - [勤務表] からの日報申請
    • [勤怠管理] - [休暇管理] からの新規申請
原因

2.15.3のワークフロー不具合対応に不備があったため

管理番号
  • 管理番号:18992
今後の対応

次回バージョンアップにて対応予定となっております。
※2014年10月29日にManageOZO 2.17.0をリリース致しました。

回避策1

自動所属ルート反映条件の下記いずれかの操作を行う
承認ルートの自動所属ルート設定について

ManageOZO側での操作

  • [ルート管理] - [ルート確認] - [ユーザー] 選択でユーザーを選択し、次へ遷移させる
  • [ルート管理] - [ルートと申請書の関連付け] - [登録/編集] - [シミュレーション] で、ユーザを選択する
  • 当該のユーザーでログインして、新規申請一覧を開く
  • 当該のユーザーでログインして、申請書を編集・コピー・再申請する
  • 当該のユーザーでログインして、ルート確認を行う
回避策2

修正パッチを適用する
本記事に添付されているZIPファイルを解凍し、下記手順でファイルを適用して下さい。
※ManageOZOを停止する必要はございません。

  1. Webサーバーにログインします。
  2. 対象ファイルをバックアップします。
    {ManageOZOインストールフォルダ}\include\work\Apply\Lvw_AddGet_act.cfm
  3. 本記事添付のZipファイルを解凍します。
  4. 対象ファイルを上書きコピーします。
    {ManageOZOインストールフォルダ}\include\work\Apply\Lvw_AddGet_act.cfm
補足情報
 ManageOZOインストールフォルダについて
下記に記載しております。
「ManageOZO セットアップ内容通知書」
 2 ManageOZO設定情報
  2.1 基本情報
   インストールディレクトリ
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